Solusi untuk Multilib version problems found di centos

jadi pagi ini saya menemukan problem seperti berikut :

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for glibc which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of glibc of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude glibc.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of glibc installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of glibc installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: glibc-2.17-323.el7_9.x86_64 != glibc-2.17-322.el7_9.i686

Solusi :

1. cek duplicate 
package-cleanup --dupes
Loaded plugins: fastestmirror, priorities
glibc-common-2.17-322.el7_9.x86_64
glibc-common-2.17-323.el7_9.x86_64

2. remove duplicate

package-cleanup --dupes glibc-common-2.17-322.el7_9.x86_64

3. update lagi

yum update -y
Klik untuk berbagi dengan orang lain
Baca Juga :  Fungsi dari lsattr dan chattr
%d bloggers like this: